The discussion has moved over to Discord

RSS Feed
Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #13086
    MechanismMechanism
    Kickstarter Backer
    Topics: 4
    Replies: 38

    Hi guys, I’ve been having intermittent, SEVERE slowdown issues with the latest betas. Build 15 was okay for me, but only after I disabled Overload’s profile in my machine’s Radeon settings. Just downloaded and hopped into build 18 and it looks like the slowdown issues are back and biting hard this time. Before it was just really slow but sort-of playable.

    Now when it slows down (to about 1fps) I can no longer move the ship and the scripting on the weapons seems to be disabled. I can fire primaries and launch missiles, but they just hang in (what I assume to be) their spawn positions for a few frames (read: about four seconds) before they actually start moving. Primaries will move as normal, but launched missiles immediately collide with my ship and cause damage.

    I’ve been monitoring my machine’s performance with Process Explorer and during these slowdowns, and have noted that CPU utilisation goes way down (~30% drop) and GPU use goes through the floor; barely even registering on the graph.

    My machine’s specs, should they be relevant, are as follows;
    GPU: Radeon RX 480
    CPU: AMD FX 8350 Octa-Core
    VRAM: 8GB GDDR5
    RAM: 32GB
    OS: Windows 10 64bit
    Swap: 4-8GB

    #13087
    Luke Schneider
    Overload Team
    Topics: 10
    Replies: 115

    Sounds like something is writing to disk, maybe? Could be a debug message being spammed to the log file (though that doesn’t make sense for a non-debug build) Either way, if you email feedback@revivalprod.com, we’ll get you a debug build that will help diagnose the issue.

    Sorry for the framerate issues.

    #13169
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    This has been happening to me as well — I reported it in the beta area because I wasn’t sure whether or not it had gone live at the time.
    Haven’t heard anything else in that thread since Thursday; if it’s easier to respond to the problem in one place I’ll put my posts here instead.

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13250
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    New finding!
    If I run the game with “-window-mode exclusive” in the launch options I still get the freeze, but I can get about twice as far into the level before it happens. So if I go as quickly as possible through the training mission I’ll freeze in the room after the first riser shaft (usually after killing the bot), instead of freezing just before I reach the shaft.

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13251
    MechanismMechanism
    Kickstarter Backer
    Topics: 4
    Replies: 38

    Yep, on the debug build I have, running in windowed mode seems to increase performance.

    #13252
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    I would really like to play this game again — I have very little else to do in my spare time while I’m up north :P. But I know you guys are working on fixing this as hard as you can; don’t mind the jealous little leopards of the world.

    The bug is definitely linked to performance, Mechanism, but unless I’m very much mistaken that can’t be all there is to it — I had much worse performance in build 15, which was the last one released prior to 18 , and no freezing issues.

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13253
    TwoCablesTwoCables
    Kickstarter Backer
    Topics: 118
    Replies: 1474

    Yep, on the debug build I have, running in windowed mode seems to increase performance.

    “-window-mode exclusive” is Exclusive Full Screen Mode.

    Prepare for Overload…

    #13254
    Mike Kulas
    Overload Team
    Topics: 24
    Replies: 186

    Splotchie — Sorry it’s not working for you. Could you help us out and put all the info in one post?

    What is your rig?

    What recent builds did work for you?

    have you run any recent debug builds?

    #13255
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    Let’s see what I can piece together…
    Item ID: Splotchie Compie & Bug

    Object Class:
    Intel Core i7 4500U CPU @ 1.80 GHz (4 of them)
    6.00 GB RAM
    nVidia GeForce GT 740M
    nVidia Virtual Audio Device (Wave Extensible) WDM
    (do you need more?)

    Yes, this is a laptop. For now I’m stuck with it… Hopefully won’t be for too too much longer. 🙂

    Special Contraption Positions:
    I haven’t run any debug builds — though I would be happy to if you think that would help. I normally have a framerate of near or around 30fps since the PAX west demo, it does drop lower sometimes but when this problem happens there’s no abnormal drop in framerate before it freezes. The last build that worked was build 15 during the beta.

    Description:
    (these are all my previous posts about the bug, excluding what’s already in this thread)

    After getting into the secret near the start of Outer Moons 3 and returning to the main entry hallway, my ship became an immovable object. Any weapons I fired would hang in the air right next to my field of view (and if it had any kind of radius damage it would hurt me too). When I leave and open another level I still have the same problem.
    The thing that seemed to trigger it was switching missiles but I’m not entirely sure about this and I’m going to test more. Just that in my current mental state if I don’t report this right now likely I forget to report it ever.

    Oh and this is the current version — build 18 I think, unless there’s been another since this morning.

    More testing:
    It happens on any level I play at any difficulty, within a few seconds of loading, even if all I do is move forwards or sideways, or fire a weapon. It doesn’t seem to happen if I only turn side to side or bank, without moving. I suspect when I thought it was caused by switching weapons the cause was actually moving forwards.
    I haven’t been able to get far enough into any map to see if or how it affects the AI.

    After a reinstall it’s still behaving the same, and it doesn’t matter how long I wait after spawning to move.

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13281
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    Heeey. Shroudeye and I had an interesting conversation in Chat that could have some bearing on this and I figured I’d put the log here on the off chance it could help you guys.

    04/05 17:29
    Shroudeye
    Well, semi-freezes.

    04/05 17:30
    Splotchie
    I can still shoot when I’m frozen, but the particles hang in the air

    04/05 17:30
    Splotchie
    and possibly damage me

    04/05 17:30
    Shroudeye
    That one, but there is no damage.

    04/05 17:30
    Shroudeye
    Also happens if you shoot flares.

    04/05 17:31
    Splotchie
    I can’t get far enough into any map to see if too many particles will hasten this

    04/05 17:31
    Splotchie
    it happens a few seconds after I start moving

    04/05 17:32
    Shroudeye
    Hmm, yours is different, I get to play the game, but it slows down or freezes considerably if there is too many particles around.

    04/05 17:32
    Shroudeye
    Most problematic ones are the Goblin’s weapons

    04/05 17:33
    Splotchie
    my performance is probably somewhat worse to begin with

    04/05 17:33
    Shroudeye
    Hmm. System related?

    04/05 17:33
    Splotchie
    not the best laptop i nthe worrld

    04/05 17:34
    Splotchie
    but I wonder

    04/05 17:34
    Splotchie
    maybe this happens when the framerate drops below a certain level

    04/05 17:35
    Shroudeye
    Hmm…

    04/05 17:35
    Splotchie
    like, instead of dropping to 15 fps it drops to 1 fps

    04/05 17:35
    Shroudeye
    The game still runs, as we can fire weapons.

    04/05 17:35
    Splotchie
    or 0

    04/05 17:36
    Splotchie
    the physics interactions could theoretically be “normal” for 0 fps

    04/05 17:36
    Splotchie
    maybe the game just thinks its running at 0 fps

    04/05 17:37
    Shroudeye
    Yeah. Only the “tick” time is so high that we can’t move at all.

    04/05 17:37
    Shroudeye
    At 0 fps it should be infinity

    04/05 17:38
    Splotchie
    waay over my head tehre

    04/05 17:38
    Splotchie
    cat’n be bothrede to splel properly on froum for gma I can’ play

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13284
    Mike Kulas
    Overload Team
    Topics: 24
    Replies: 186

    We’ll have a debug build for testing, probably this weekend. Sorry for the slowness on our side.

    #13289
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    Well I know I’ll have the time. The only other thing I’m really able to do this weekend is a little bit of recording.

    Morning light would work best if that can be arranged. Between the sun and the snow and the house where I’m staying it’s very difficult to make out graphical details on a screen between noon and sunset.

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13298
    centro
    Participant
    Topics: 0
    Replies: 1

    We’ll have a debug build for testing, probably this weekend. Sorry for the slowness on our side.

    Just to make you aware. I’m running th game on an I7 3.5GHz with 980GTX and am having the same problems. Onc my ship freezes it stays frozen. Frame rate indicator states 20FPS but can only fire weapons and not move.

    addendum. I lowered my resolution to the next lowest from 3840 and I’m no longer getting the problem in story mode. I’ll keep testing.

    #13369
    Haunted ParraspHaunted Parrasp
    Kickstarter Backer
    Topics: 31
    Replies: 428

    Any more news on the debug build front?
    I only ask because I’m leaving tomorrow — if you’ve got it ready today I can get back to you before the long weekend.

    Ship’s cat, MPSV Iberia
    Check out his original music @ http://vertigofox.bandcamp.com/

    #13370
    Mike Kulas
    Overload Team
    Topics: 24
    Replies: 186

    I’m sorry — the build is ready. On the main menu, the build number is incorrectly labeled 17. It should be 18 — it has the same content as the regular #18 build.

    You need to allow Steam betas. The code is: impulsefalcondebug

    Then select beta_debug.

Next Unread Topic:
Viewing 15 posts - 1 through 15 (of 22 total)

Forums are currently locked.


Previous Topic: Version 0.2, Build 18 available! Next Topic: Size of tracking cone for smash attack